​Joomla! : Gestion de la sécurité

Migrer de Joomla! 2.5 vers 3.x

Testez gratuitement nos 1324 formations

pendant 10 jours !

Tester maintenant Afficher tous les abonnements
Faut-il envisager une migration ou optimiser la sécurité d'une version obsolète ? Suivez la préparation de Joomla! en vue d'une migration de version.

Transcription

Comme tout système informatique, Joomla évolue au fil du temps et se bonifie. Les dernières versions sont plus stables et sécurisées. Alors Quid, une ancienne version de Joomla, cela peut poser des problèmes de sécurité puisqu'il n'y a plus de mise à jour, par exemple Joomla 2.5 n'a plus de support depuis un certain temps, bon, il y a eu un petit patch récemment quand même de sécurité mais ils ne parleront pas des versions 1.5 et 1.0. Alors il peut arriver que la migration ne soit pas possible. Il faut l'envisager bien sur, mais il peut arriver qu'elle ne soit pas possible pour des raisons par exemple d'extensions de composants qu'on ne trouve plus et qui soient indispensables, des questions de coût, des questions de serveur. Alors nous avons encore beaucoup de sites avec des versions, je dirais anciennes. Alors on peut continuer avec ces sites, il est important de faire des mises à jour sur la dernière version, donc en ce qui concerne la 2.5 c'est la 2.5.28, donc ce sera la dernière version, il n'y en aura plus d'autre mais au moins elle est à jour. J'ai vu récemment des sites qui étaient même pas sur cette version, qui étaient sur une version qui était très peu sécurisée. Deuxième chose, faire les mises à jour des extensions, certains développeurs d'extension continuent à faire des mises à jour sur ces versions-là, donc continuez à faire les mises à jour si besoin. Faire des sauvegardes régulières et installer un pare-feu comme aeSecure. Maintenant, le mieux effectivement, c'est de passer à la version supérieure parce que vous aurez que des avantages. Avant de migrer vers la version 3.x, donc ici dans notre cas 2.5 vers la version 3.x, la plus récente, il faut vérifier quelques prérequis, la version du PHP, il faut que ce soit au moins une 5.5 voir plus, au minimum une 5.3.10 mais on a vu que le PHP était aussi un facteur de sécurité, donc plus vous avez une version haute de PHP, mieux c'est. Et une version de MySQL 5.1 ou plus. Alors la migration se passe en plusieurs étapes, la première c'est de faire une sauvegarde du site de production, du site actuel Alors de restaurer cette sauvegarde dans un environnement de test alors cela peut être sur un serveur local avec Wamp ou autre, ou mieux, de tester ça sur un serveur réel, voir même sur le même serveur de production mais de créer un espace à part pour pouvoir faire des tests de migration. Evaluer les extensions, on va voir si les extensions peuvent être mises à jour aussi. Préparer donc la migration, effectuer la migration, donc là on verra que c'est une migration en un clic, le 2.5 à 3.x Faire les tests, et publier le site en production. Donc nous venons de faire une copie de notre site dans un environnement de test, et nous allons supprimer toutes les extensions qui sont inutiles, donc dans Gestion des Extensions, en cliquant ici sur l'onglet Gestion. Alors on va filtrer, on va commencer par tous ce qui est Paquets, les packages, parce qu'ils contiennent plusieurs choses et quand on supprime, on supprime beaucoup de choses. Donc là effectivement, si vous n'utilisez pas Kunena Forum, par exemple, vous pouvez le supprimer, alors en cochant ici et en désinstallant. Donc appliquer la même procédure pour les Composants, pour les Fichiers, pour tous les types d'objets que vous avez sur votre site, on fait le ménage, on supprime tout ce qui n'est pas utilisé. Etape suivante, c'est évaluer les extensions qui restent, est-ce que ces extensions vont être compatibles avec la nouvelle version de Joomla? Alors toujours dans le Gestionnaire d'Extensions, et bien on va procéder là aussi par type, Composants, Modules,Plug-in, Templates, n'oubliez pas votre template. Donc ici vous avez des indications pour certaines extensions, vous avez des indications de compatibilité. Donc ce sont des extensions qui ont des packages pour version 2.5 et pour version 3.x, c'est à dire que cela ne posera pas de problèmes, on va faire la mise à jour de Joomla et on fera la mise à jour des extensions, cela ne devrait pas poser de problèmes. pour d'autres extensions, et bien il y a une version 2.5 et il y a une version 3, donc il faudra après la mise à jour de Joomla, réinstaller la nouvelle version et peut-être faire certaines adaptations dans les paramétrages, donc là il faut lister vraiment toutes les extensions, composants, les modules, les plugins et aller sur les sites des éditeurs et voir un petit peu ce qu'ils conseillent en cas de migration. Alors il y a des éditeurs qui n'existent plus donc des extensions qui ne seront plus jamais mises à jour, celles-là il faut s'en passer ou trouver un substitut. Donc voir si, par exemple un formulaire, en esperant qu'il y a eu des gestionnaires de formulaire très populaire sur les sites en France, ils n'existent plus, on va être obligé de remplacer par un autre système de formulaire et de recréer le formulaire pratiquement depuis zero. Vérifier également le template, il y a des éditeurs qui mettent à jour leur template, de la version 2.5 à la version .3. Vérifier si le template a été mis à jour, si c'est pas le cas, là aussi il faudra s'adapter, pour refaire faire un template ou prendre un template différent. C'est peut-être l'occasion aussi de changer de look, une migration. Alors il reste le cas des extensions qui ont été personnalisées, modifiées dans le code, et bien dans le code PHP c'est un peu plus délicat, soit on refait l'extension, soit souvent c'est là où on est amené à rester dans la version actuelle et ne pas pouvoir évoluer. Bien, nous avons fait le point un petit peu sur la préparation de la migration d'un site Joomla 2.5 vers une version 3, dans la vidéo prochaine, et bien nous allons passer directement à la migration en un clic.

​Joomla! : Gestion de la sécurité

​Respectez quelques règles, souvent simples et de bon sens, pour éviter de perdre tout le contenu de votre site Joomla!. Sachez prévenir et réagir en cas d’attaque !

1h47 (26 vidéos)
Aucun commentaire n´est disponible actuellement
 
Logiciel :
Thématiques :
Design web
CMS
Spécial abonnés
Date de parution :21 avr. 2016

Votre formation est disponible en ligne avec option de téléchargement. Bonne nouvelle : vous ne devez pas choisir entre les deux. Dès que vous achetez une formation, vous disposez des deux options de consultation !

Le téléchargement vous permet de consulter la formation hors ligne et offre une interface plus conviviale. Si vous travaillez sur différents ordinateurs ou que vous ne voulez pas regarder la formation en une seule fois, connectez-vous sur cette page pour consulter en ligne les vidéos de la formation. Nous vous souhaitons un excellent apprentissage avec cette formation vidéo.

N'hésitez pas à nous contacter si vous avez des questions !